summaryrefslogtreecommitdiff
path: root/test/unit/CMakeLists.txt
diff options
context:
space:
mode:
authorGereon Kremer <gereon.kremer@cs.rwth-aachen.de>2020-07-17 09:06:31 +0200
committerGitHub <noreply@github.com>2020-07-17 00:06:31 -0700
commit0a7e733a5cee4733ca8ca9fff1f6eab6fc22a549 (patch)
tree8df7919ddfa7e3d3b6207f61edddfac6ed204305 /test/unit/CMakeLists.txt
parent2ee5a2bcf5fd7aaf72d44553ebb85edd76fd06c8 (diff)
Integration of libpoly (#4679)
This commit integrates LibPoly into CVC4. It adds `contrib/get-poly`, adds it to the configure script, cmake and places where CVC4 inspects its own build configuration. Furthermore, it adds `CVC4::RealAlgebraicNumber` (which wraps `poly::AlgebraicNumber`) including some basic unit tests and some utilities.
Diffstat (limited to 'test/unit/CMakeLists.txt')
-rw-r--r--test/unit/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/unit/CMakeLists.txt b/test/unit/CMakeLists.txt
index 9b9a2a100..bd7c1ea22 100644
--- a/test/unit/CMakeLists.txt
+++ b/test/unit/CMakeLists.txt
@@ -65,6 +65,10 @@ macro(cvc4_add_unit_test is_white name output_dir)
# We don't link against LFSC, because CVC4 is already linked against it.
target_include_directories(${name} PRIVATE ${LFSC_INCLUDE_DIR})
endif()
+ if(USE_POLY)
+ # We don't link against libpoly, because CVC4 is already linked against it.
+ target_include_directories(${name} PRIVATE ${POLY_INCLUDE_DIR})
+ endif()
if(${is_white})
target_compile_options(${name} PRIVATE -fno-access-control)
endif()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback