summaryrefslogtreecommitdiff
path: root/test/unit/CMakeLists.txt
diff options
context:
space:
mode:
authorGereon Kremer <gereon.kremer@cs.rwth-aachen.de>2021-03-31 23:17:38 +0200
committerGitHub <noreply@github.com>2021-03-31 21:17:38 +0000
commitf9a9af855fb65804ff0b36e764ccd9d0fa9f87f8 (patch)
tree2c90b0e704366541187198231102b2d1eed26f41 /test/unit/CMakeLists.txt
parent39ea1d8a1497a83d1efc649bd10da82916e5db5f (diff)
Refactor GMP and Poly dependencies (#6245)
Refactors GMP and libpoly to also use external projects and be available within cmake as proper targets.
Diffstat (limited to 'test/unit/CMakeLists.txt')
-rw-r--r--test/unit/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/test/unit/CMakeLists.txt b/test/unit/CMakeLists.txt
index c8c2b0d65..7b82f3346 100644
--- a/test/unit/CMakeLists.txt
+++ b/test/unit/CMakeLists.txt
@@ -46,11 +46,9 @@ macro(cvc4_add_unit_test is_white name output_dir)
target_include_directories(${name} PRIVATE $<BUILD_INTERFACE:${CLN_INCLUDE_DIR}>)
endif()
if(USE_POLY)
- target_link_libraries(${name} ${POLY_LIBRARIES})
- target_include_directories(${name} PRIVATE ${POLY_INCLUDE_DIR})
+ target_link_libraries(${name} Polyxx)
endif()
- target_link_libraries(${name} ${GMP_LIBRARIES})
- target_include_directories(${name} PRIVATE ${GMP_INCLUDE_DIR})
+ target_link_libraries(${name} GMP)
if(${is_white})
target_compile_options(${name} PRIVATE -fno-access-control)
endif()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback