summaryrefslogtreecommitdiff
path: root/test/unit/CMakeLists.txt
diff options
context:
space:
mode:
authorGereon Kremer <gereon.kremer@cs.rwth-aachen.de>2021-03-30 00:24:46 +0200
committerGitHub <noreply@github.com>2021-03-29 22:24:46 +0000
commitef31c2518c194029a913fe2872e2040d2f5e4294 (patch)
tree216abc5f72110d34d99fd345566fee9bc36ce736 /test/unit/CMakeLists.txt
parent96ac1d2a5d1f25eaa1b0b265bb21d1a8b3c3d872 (diff)
Add external project to install gtest (#6229)
This PR enables us to build gtest ourselves if it is not already installed.
Diffstat (limited to 'test/unit/CMakeLists.txt')
-rw-r--r--test/unit/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/unit/CMakeLists.txt b/test/unit/CMakeLists.txt
index f63f3f315..7163b5a12 100644
--- a/test/unit/CMakeLists.txt
+++ b/test/unit/CMakeLists.txt
@@ -38,8 +38,8 @@ macro(cvc4_add_unit_test is_white name output_dir)
target_compile_definitions(${name} PRIVATE ${CVC4_UNIT_TEST_FLAGS_BLACK})
gtest_add_tests(TARGET ${name})
target_link_libraries(${name} main-test)
- target_link_libraries(${name} GTest::GTest)
target_link_libraries(${name} GTest::Main)
+ target_link_libraries(${name} GTest::GTest)
if(USE_POLY)
# We don't link against libpoly, because CVC4 is already linked against it.
target_include_directories(${name} PRIVATE ${POLY_INCLUDE_DIR})
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback