summaryrefslogtreecommitdiff
path: root/test/unit/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-08-17 16:57:20 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commit67b04a7cb5dd7efd72065e4aad7700b6714400fb (patch)
treeb0dfd9c48e044d686ef41e4d968ec96c5d22529e /test/unit/CMakeLists.txt
parent6b8fa31e4ab33004308df0716c4e3d1cecd2ae55 (diff)
cmake: Disable W-suggest-override for unit tests.
Diffstat (limited to 'test/unit/CMakeLists.txt')
-rw-r--r--test/unit/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/unit/CMakeLists.txt b/test/unit/CMakeLists.txt
index 57a50f52e..b29c705c1 100644
--- a/test/unit/CMakeLists.txt
+++ b/test/unit/CMakeLists.txt
@@ -16,6 +16,9 @@ macro(cvc4_add_unit_test is_white name)
if(${is_white})
target_compile_options(${name} PRIVATE -fno-access-control)
endif()
+ # Disable the Wsuggest-override warnings for the unit tests. CxxTest generates
+ # code that does not properly add the override keyword to runTest().
+ target_compile_options(${name} PRIVATE -Wno-suggest-override)
endmacro()
macro(cvc4_add_unit_test_black name)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback