summaryrefslogtreecommitdiff
path: root/test/unit/CMakeLists.txt
diff options
context:
space:
mode:
authorAina Niemetz <aina.niemetz@gmail.com>2018-09-14 14:21:35 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commit0a41a21cedc789262f3035aa91ff6b924f309b4e (patch)
treeeae28a622352c818e043b0ac3adba60c3e14a0c3 /test/unit/CMakeLists.txt
parent15a7249a2aa33187e766d6f828a503e5c937b9cf (diff)
cmake: Do not build examples and unit and system tests by default.
Diffstat (limited to 'test/unit/CMakeLists.txt')
-rw-r--r--test/unit/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/test/unit/CMakeLists.txt b/test/unit/CMakeLists.txt
index 0123ae7ff..5e45654a9 100644
--- a/test/unit/CMakeLists.txt
+++ b/test/unit/CMakeLists.txt
@@ -16,6 +16,12 @@ set(CVC4_CXXTEST_FLAGS_BLACK
set(CVC4_CXXTEST_FLAGS_WHITE -fno-access-control ${CVC4_CXXTEST_FLAGS_BLACK})
macro(cvc4_add_unit_test is_white name)
+ # cxxtest_add_test generates the unit test executables into directory
+ # CMAKE_BINARY_DIR/test/unit by default and does not allow to change this
+ # location (it's possible to set corresponding target properties with
+ # set_target_properties, but then the test environment does not find them).
+ # Hence, these are the only executables that are not generated into our
+ # default directory for executables (CMAKE_BINARY_DIR/bin).
cxxtest_add_test(${name} ${name}.cpp ${CMAKE_CURRENT_LIST_DIR}/${name}.h)
set_tests_properties(${name} PROPERTIES LABELS "unit")
target_link_libraries(${name} main-test)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback