summaryrefslogtreecommitdiff
path: root/test/system/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2012-08-28 01:10:16 +0000
committerMorgan Deters <mdeters@gmail.com>2012-08-28 01:10:16 +0000
commitcf287f593931a1c4fc141e18845b4c5d36879889 (patch)
tree4dad0f555b7db01fbeedcd9eace394cd8f7a0fb4 /test/system/Makefile.am
parentb7b1c1d99ffa333704af2c8ecd60b1af8833a28b (diff)
Improved compatibility layer, now supports quantifiers. Also incorporates
numerous bugfixes, and the cvc3 system test is enabled.
Diffstat (limited to 'test/system/Makefile.am')
-rw-r--r--test/system/Makefile.am21
1 files changed, 17 insertions, 4 deletions
diff --git a/test/system/Makefile.am b/test/system/Makefile.am
index 5fcc8833a..836189991 100644
--- a/test/system/Makefile.am
+++ b/test/system/Makefile.am
@@ -5,7 +5,11 @@ CPLUSPLUS_TESTS = \
ouroborous \
two_smt_engines \
smt2_compliance
-# cvc3_main
+
+if CVC4_BUILD_LIBCOMPAT
+CPLUSPLUS_TESTS += \
+ cvc3_main
+endif
TESTS = $(CPLUSPLUS_TESTS)
@@ -32,9 +36,13 @@ TEST_DEPS_DIST = \
# changes made in the header files.
TEST_DEPS_NODIST = \
$(abs_top_builddir)/src/libcvc4.la \
- $(abs_top_builddir)/src/parser/libcvc4parser.la \
+ $(abs_top_builddir)/src/parser/libcvc4parser.la
+
+if CVC4_BUILD_LIBCOMPAT
+TEST_DEPS_NODIST += \
$(abs_top_builddir)/src/compat/libcvc4compat.la \
cvc3_george.lo
+endif
TEST_DEPS = \
$(TEST_DEPS_DIST) \
@@ -63,8 +71,13 @@ AM_CPPFLAGS = \
-D __STDC_FORMAT_MACROS \
-D __BUILDING_CVC4_SYSTEM_TEST \
$(TEST_CPPFLAGS)
-LIBADD = \
- @abs_top_builddir@/src/compat/libcvc4compat.la \
+
+LIBADD =
+if CVC4_BUILD_LIBCOMPAT
+LIBADD += \
+ @abs_top_builddir@/src/compat/libcvc4compat.la
+endif
+LIBADD += \
@abs_top_builddir@/src/parser/libcvc4parser.la \
@abs_top_builddir@/src/libcvc4.la
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback