summaryrefslogtreecommitdiff
path: root/test/system/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-03-08 23:49:47 +0000
committerMorgan Deters <mdeters@gmail.com>2010-03-08 23:49:47 +0000
commitcf4d347cbbbb4c1a1e1db99337cfd2b22b84b756 (patch)
treeceea43e3d37525038bed10b115c73a8aa08ce68d /test/system/Makefile.am
parentde0160112edbed8ce9b62bf87172ae2f0e99a013 (diff)
This fixes regressions at levels >= 1 which were failing
* implement zombification and garbage collection of NodeValues (but GC not turned on yet) * implement removal of key nodes from all attribute tables * audit NodeBuilder and fix memory leaks and improper reference-count management. This is in many places a re-write. Clearly documented invariants on NodeBuilder state. (Closes Bug 38) * created a "BackedNodeBuilder" that can be used to construct NodeBuilders with a stack-based backing store for a size that's not a compile-time constant. * NodeValues no longer depend on Node for toStream()'ing * make unit test-building "silent" with --enable-silent-rules * (Makefile.am, Makefile.builds.in) fix top-level build system so that "make regressN" works with unbuilt/out-of-date source trees in the expected way. * (various) code cleanup, documentation, formatting
Diffstat (limited to 'test/system/Makefile.am')
-rw-r--r--test/system/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/test/system/Makefile.am b/test/system/Makefile.am
index 15f781333..59a37a4db 100644
--- a/test/system/Makefile.am
+++ b/test/system/Makefile.am
@@ -22,6 +22,17 @@ TEST_DEPS = \
EXTRA_DIST = \
$(TEST_DEPS_DIST)
+if STATIC_BINARY
+system_LINK = $(CXXLINK) -all-static
+else
+system_LINK = $(CXXLINK)
+endif
+
+# WHEN SYSTEM TESTS ARE ADDED, BUILD LIKE THIS:
+# system_test: system_test.cpp
+# $(AM_V_CXX)$(LTCXXCOMPILE) $(AM_CXXFLAGS) -c -o $@.lo $<
+# $(AM_V_CXXLD)$(system_LINK) $(AM_LDFLAGS) $@.lo
+
# rebuild tests if a library changes
$(TESTS):: $(TEST_DEPS)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback