summaryrefslogtreecommitdiff
path: root/test/regress/regress0/sygus/Makefile.am
diff options
context:
space:
mode:
authorajreynol <andrew.j.reynolds@gmail.com>2017-07-10 14:06:52 -0500
committerajreynol <andrew.j.reynolds@gmail.com>2017-07-10 14:07:11 -0500
commitf3590092818d9eab9d961ea602093029ff472a85 (patch)
tree1401f00df0d9659ba2321ea2088fe0c3f4de9f52 /test/regress/regress0/sygus/Makefile.am
parentd598a9644862d176632071bca8448765d9cc3cc1 (diff)
Merge datatype shared selectors/sygus comp 2017 branch. Modify the datatypes decision procedure to share selectors of the same type across multiple constructors. Major rewrite of the SyGuS solver. Adds several new strategies for I/O example problems (PBE) and invariant synthesis. Major simplifications to sygus parsing and synthesis conjecture representation. Do not support check-synth in portfolio. Add sygus regressions.
Diffstat (limited to 'test/regress/regress0/sygus/Makefile.am')
-rw-r--r--test/regress/regress0/sygus/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/test/regress/regress0/sygus/Makefile.am b/test/regress/regress0/sygus/Makefile.am
index 0764b5d77..0786c3f31 100644
--- a/test/regress/regress0/sygus/Makefile.am
+++ b/test/regress/regress0/sygus/Makefile.am
@@ -50,7 +50,19 @@ TESTS = commutative.sy \
no-mention.sy \
max2-univ.sy \
strings-small.sy \
- strings-unconstrained.sy
+ strings-unconstrained.sy \
+ tl-type-4x.sy \
+ tl-type-0.sy \
+ fg_polynomial3.sy \
+ icfp_14.12.sy \
+ strings-trivial-simp.sy \
+ icfp_easy-ite.sy \
+ strings-template-infer.sy \
+ strings-trivial.sy \
+ General_plus10.sy \
+ qe.sy \
+ cggmp.sy
+
# sygus tests currently taking too long for make regress
EXTRA_DIST = $(TESTS) \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback