summaryrefslogtreecommitdiff
path: root/test/regress/regress0/arith/Makefile.am
diff options
context:
space:
mode:
authorTim King <taking@cs.nyu.edu>2010-09-14 19:37:31 +0000
committerTim King <taking@cs.nyu.edu>2010-09-14 19:37:31 +0000
commited3bc77005060a5745696519da31babd745181a7 (patch)
tree9c709913c6f8f10145ecf00833bc775ad4debb33 /test/regress/regress0/arith/Makefile.am
parentd37cfff40c4e72f476b3ee5c1eb2c0f9790fcf00 (diff)
* added test/regress/regress0/arith for easy arithmetic regress tests.
Diffstat (limited to 'test/regress/regress0/arith/Makefile.am')
-rw-r--r--test/regress/regress0/arith/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/test/regress/regress0/arith/Makefile.am b/test/regress/regress0/arith/Makefile.am
new file mode 100644
index 000000000..e4fc110b4
--- /dev/null
+++ b/test/regress/regress0/arith/Makefile.am
@@ -0,0 +1,28 @@
+TESTS_ENVIRONMENT = @srcdir@/../../run_regression @top_builddir@/src/main/cvc4
+
+# These are run for all build profiles.
+# If a test shouldn't be run in e.g. competition mode,
+# put it below in "TESTS +="
+TESTS = \
+ arith.01.cvc \
+ arith.02.cvc
+
+EXTRA_DIST = $(TESTS)
+
+#if CVC4_BUILD_PROFILE_COMPETITION
+#else
+#TESTS += \
+# error.cvc
+#endif
+#
+# and make sure to distribute it
+#EXTRA_DIST += \
+# error.cvc
+
+# synonyms for "check"
+.PHONY: regress regress0 test
+regress regress0 test: check
+
+# do nothing in this subdir
+.PHONY: regress1 regress2 regress3
+regress1 regress2 regress3:
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback