summaryrefslogtreecommitdiff
path: root/test/regress/regress0/arith/Makefile.am
diff options
context:
space:
mode:
authorTim King <taking@cs.nyu.edu>2012-06-14 19:29:25 +0000
committerTim King <taking@cs.nyu.edu>2012-06-14 19:29:25 +0000
commit2581001b96a64e1d11d826cf554d378ac522bbe2 (patch)
tree438024c782ce3a92aa44559772a6c4378332f958 /test/regress/regress0/arith/Makefile.am
parentda1e7aaacab8dd4e9b80b752f362d190c1472543 (diff)
Fixed arithmetic consistency issue. The simplex conflict variable had to be reenqueued so that the queue was a superset of the failing assertions. This adds a super expensive debug routine unenqueuedVariablesAreConsistent() that catches this bug. This is enabled when -d arith::consistency is turned on. make check passes with this flag enabled.
Diffstat (limited to 'test/regress/regress0/arith/Makefile.am')
-rw-r--r--test/regress/regress0/arith/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/regress/regress0/arith/Makefile.am b/test/regress/regress0/arith/Makefile.am
index 19837d8f1..ffa52ef56 100644
--- a/test/regress/regress0/arith/Makefile.am
+++ b/test/regress/regress0/arith/Makefile.am
@@ -19,7 +19,8 @@ TESTS = \
delta-minimized-row-vector-bug.smt \
fuzz_3-eq.smt \
leq.01.smt \
- miplibtrick.smt
+ miplibtrick.smt \
+ DTP_k2_n35_c175_s15.smt2
# problem__003.smt2
EXTRA_DIST = $(TESTS)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback