summaryrefslogtreecommitdiff
path: root/test/regress/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Reynolds <andrew.j.reynolds@gmail.com>2021-08-23 16:42:14 -0500
committerGitHub <noreply@github.com>2021-08-23 21:42:14 +0000
commit982b585a1b766a933055d7328579cdb482504fe4 (patch)
tree085328ba996448cd3926468770ba858b4b0c2f14 /test/regress/CMakeLists.txt
parentb272d60452028025d56dbf6ffe10276d6f9281cb (diff)
Generalize inequality elimination in quantifiers rewriter (#7030)
This generalizes our inequality elimination technique to handle disequalities as well as inequalities. #6999 is an example where a variable can be eliminated: if a variable x occurs only in an equality with negative required polarity, then the variable and that literal can be eliminated. Fixes #6999.
Diffstat (limited to 'test/regress/CMakeLists.txt')
-rw-r--r--test/regress/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/regress/CMakeLists.txt b/test/regress/CMakeLists.txt
index d68400b66..55649c2f0 100644
--- a/test/regress/CMakeLists.txt
+++ b/test/regress/CMakeLists.txt
@@ -911,6 +911,7 @@ set(regress_0_tests
regress0/quantifiers/issue5693-prenex.smt2
regress0/quantifiers/issue6603-dt-bool-cegqi.smt2
regress0/quantifiers/issue6996-trivial-elim.smt2
+ regress0/quantifiers/issue6999-deq-elim.smt2
regress0/quantifiers/lra-triv-gn.smt2
regress0/quantifiers/macro-back-subs-sat.smt2
regress0/quantifiers/macros-int-real.smt2
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback