summaryrefslogtreecommitdiff
path: root/test/regress/CMakeLists.txt
diff options
context:
space:
mode:
authorAndres Noetzli <andres.noetzli@gmail.com>2018-10-02 20:56:36 -0700
committerGitHub <noreply@github.com>2018-10-02 20:56:36 -0700
commitb1fe934c551dd89f1001ca2c56a146231c1e49a0 (patch)
treea2b37c7fb8432bf289217a07fa95ae3ba9ce727d /test/regress/CMakeLists.txt
parentc48dd01b92f4704c99ca6833b94759dee42106a8 (diff)
cmake: Display skipped tests as not run (#2567)
Currently, the run_regression.py script just returns 0 when we skip a test due to a feature not supported by the current configuration. Returning 0 marks those tests as passed. To make it more clear which tests were skipped, this commit adds the `SKIP_RETURN_CODE` [0] property to the regression tests and changes the regression script to return 77 for skipped tests. The feature is supported since at least CMake 3.0 [0]. For backwards compatibility with autotools, returning 77 for skipped tests is only active when `--cmake` is passed to the run_regression.py script. [0] https://cmake.org/cmake/help/v3.0/prop_test/SKIP_RETURN_CODE.html
Diffstat (limited to 'test/regress/CMakeLists.txt')
-rw-r--r--test/regress/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/test/regress/CMakeLists.txt b/test/regress/CMakeLists.txt
index fd4026dc0..c798af378 100644
--- a/test/regress/CMakeLists.txt
+++ b/test/regress/CMakeLists.txt
@@ -2091,9 +2091,12 @@ add_custom_target(regress
macro(cvc4_add_regression_test level file)
add_test(${file}
${run_regress_script}
+ --cmake
${RUN_REGRESSION_ARGS}
${path_to_cvc4}/cvc4 ${CMAKE_CURRENT_LIST_DIR}/${file})
- set_tests_properties(${file} PROPERTIES LABELS "regress${level}")
+ set_tests_properties(${file} PROPERTIES
+ LABELS "regress${level}"
+ SKIP_RETURN_CODE 77)
endmacro()
foreach(file ${regress_0_tests})
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback