summaryrefslogtreecommitdiff
path: root/test/regress/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-09-20 16:32:27 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commit3b433d829ccfc0d91cb98f368a8896f5ccad1671 (patch)
tree1f52824fbfe88eb3a94594c5f4cf87a30a3f0803 /test/regress/CMakeLists.txt
parente86a06829491bae68cef1b2156d245874516fd17 (diff)
cmake: Run make coverage in parallel by default.
Diffstat (limited to 'test/regress/CMakeLists.txt')
-rw-r--r--test/regress/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/regress/CMakeLists.txt b/test/regress/CMakeLists.txt
index e0bdc2bfc..88be6b94b 100644
--- a/test/regress/CMakeLists.txt
+++ b/test/regress/CMakeLists.txt
@@ -2075,7 +2075,8 @@ get_target_property(path_to_cvc4 cvc4-bin RUNTIME_OUTPUT_DIRECTORY)
set(run_regress_script ${CMAKE_CURRENT_LIST_DIR}/run_regression.py)
add_custom_target(regress
- COMMAND ctest --output-on-failure -L "regress[0-1]" -j${NTHREADS} $(ARGS)
+ COMMAND
+ ctest --output-on-failure -L "regress[0-1]" -j${CTEST_NTHREADS} $(ARGS)
DEPENDS cvc4-bin)
macro(cvc4_add_regression_test level file)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback