summaryrefslogtreecommitdiff
path: root/test/regress/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-10-01 15:53:30 -0700
committerGitHub <noreply@github.com>2018-10-01 15:53:30 -0700
commit968d12fb8dc668dde59b02923a6b9ec20ecbeb3f (patch)
tree41bd185dfea8fbf29bb5b083d38e49b3a40c3d9c /test/regress/CMakeLists.txt
parent6b718154dfbf5e9f8506d6911201bb7398ba8b48 (diff)
cmake: Add build target build-tests to build all test dependencies. (#2558)
Diffstat (limited to 'test/regress/CMakeLists.txt')
-rw-r--r--test/regress/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/test/regress/CMakeLists.txt b/test/regress/CMakeLists.txt
index 79b706fdb..ecd98ddc2 100644
--- a/test/regress/CMakeLists.txt
+++ b/test/regress/CMakeLists.txt
@@ -2080,10 +2080,7 @@ get_target_property(path_to_cvc4 cvc4-bin RUNTIME_OUTPUT_DIRECTORY)
set(run_regress_script ${CMAKE_CURRENT_LIST_DIR}/run_regression.py)
add_custom_target(build-regress DEPENDS cvc4-bin)
-add_dependencies(check build-regress)
-if(ENABLE_COVERAGE)
- add_dependencies(coverage build-regress)
-endif()
+add_dependencies(build-tests build-regress)
add_custom_target(regress
COMMAND
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback