summaryrefslogtreecommitdiff
path: root/test/regress/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Reynolds <andrew.j.reynolds@gmail.com>2020-03-05 14:38:16 -0600
committerGitHub <noreply@github.com>2020-03-05 14:38:16 -0600
commitd26ee67911fedfef966a0e4d64ffda02007d65a0 (patch)
treed8d5511eeb12ecace73845785546df95e8f67f1f /test/regress/CMakeLists.txt
parent04039407e6308070c148de0d5e93640ec1b0a341 (diff)
Fix issues with real to int (#3918)
This fixes a few issues in the real to int preprocessing pass. Previously it was not robust to cases where the input had constraints that were not over the reals. Fixes #3915 and fixes #3913 and fixes #3916.
Diffstat (limited to 'test/regress/CMakeLists.txt')
-rw-r--r--test/regress/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/regress/CMakeLists.txt b/test/regress/CMakeLists.txt
index 34f7a8713..a7d931246 100644
--- a/test/regress/CMakeLists.txt
+++ b/test/regress/CMakeLists.txt
@@ -682,6 +682,7 @@ set(regress_0_tests
regress0/push-pop/incremental-subst-bug.cvc
regress0/push-pop/issue1986.smt2
regress0/push-pop/issue2137.min.smt2
+ regress0/push-pop/issue3915-real-as-int.smt2
regress0/push-pop/quant-fun-proc-unfd.smt2
regress0/push-pop/simple_unsat_cores.smt2
regress0/push-pop/test.00.cvc
@@ -1508,6 +1509,7 @@ set(regress_1_tests
regress1/quantifiers/qe.smt2
regress1/quantifiers/quant-wf-int-ind.smt2
regress1/quantifiers/quaternion_ds1_symm_0428.fof.smt2
+ regress1/quantifiers/real-to-int-quant.smt2
regress1/quantifiers/recfact.cvc
regress1/quantifiers/rel-trigger-unusable.smt2
regress1/quantifiers/repair-const-nterm.smt2
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback