summaryrefslogtreecommitdiff
path: root/test/api/CMakeLists.txt
diff options
context:
space:
mode:
authorGereon Kremer <gereon.kremer@cs.rwth-aachen.de>2021-03-31 21:16:05 +0200
committerGitHub <noreply@github.com>2021-03-31 19:16:05 +0000
commitb7210ed60d517aebb25c23a2f407ee59562587dd (patch)
tree082a225b399f5db85d3cda3dfe0c410090244433 /test/api/CMakeLists.txt
parenta779d33c559e5e494e71ca1a0c744d0275b31b5c (diff)
Refactor SymFPU dependency (#6218)
This PR refactors the contrib script to download SymFPU to a cmake external project.
Diffstat (limited to 'test/api/CMakeLists.txt')
-rw-r--r--test/api/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/test/api/CMakeLists.txt b/test/api/CMakeLists.txt
index bc185140f..239c32c94 100644
--- a/test/api/CMakeLists.txt
+++ b/test/api/CMakeLists.txt
@@ -32,6 +32,12 @@ macro(cvc4_add_api_test name)
add_executable(${name} ${name}.cpp)
target_link_libraries(${name} main-test)
target_compile_definitions(${name} PRIVATE ${CVC4_API_TEST_FLAGS})
+ if(USE_CLN)
+ target_link_libraries(${name} ${CLN_LIBRARIES})
+ target_include_directories(${name} PRIVATE $<BUILD_INTERFACE:${CLN_INCLUDE_DIR}>)
+ endif()
+ target_link_libraries(${name} ${GMP_LIBRARIES})
+ target_include_directories(${name} PRIVATE $<BUILD_INTERFACE:${GMP_INCLUDE_DIR}>)
set_target_properties(${name}
PROPERTIES RUNTIME_OUTPUT_DIRECTORY ${test_bin_dir})
add_test(api/${name} ${test_bin_dir}/${name})
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback