summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2009-11-20 23:47:56 +0000
committerMorgan Deters <mdeters@gmail.com>2009-11-20 23:47:56 +0000
commit95e5ca98d4c22897c0192a78ebeeb05e4838db2b (patch)
tree7bd14dc25a240bc2b4f5152c4ee7b666763dbebe /test/Makefile.am
parentcb56555734b5139f779e65cc6e628124ac6796e6 (diff)
fixes to build/test system
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am24
1 files changed, 1 insertions, 23 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index bf74eaa47..ff449f768 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,23 +1 @@
-if HAVE_CXXTESTGEN
-
-AM_CPPFLAGS = -I. "-I$(CXXTEST)" "-I@top_srcdir@/src/include" "-I@top_srcdir@/src"
-AM_CXXFLAGS = -fno-access-control
-AM_LDFLAGS = -L@top_builddir@/src/libcvc4.a
-TESTS = \
- expr/expr_black \
- expr/expr_white
-
-%.cpp: %.h
- $(CXXTESTGEN) --have-eh --have-std --error-printer -o $@ $<
-%: %.cpp
- $(CXX) $(TEST_CPPFLAGS) $(AM_CPPFLAGS) $(TEST_CXXFLAGS) $(AM_CXXFLAGS) -o $@ $(TEST_LDFLAGS) $(AM_LDFLAGS) $< @top_builddir@/src/libcvc4.a
-
-MOSTLYCLEANFILES = $(TESTS) $(TESTS:%=%.cpp)
-
-else
-
-# force a user-visible failure for "make check"
-TESTS = no_cxxtest
-
-endif
-
+SUBDIRS = unit regress
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback