summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2009-11-19 22:07:01 +0000
committerMorgan Deters <mdeters@gmail.com>2009-11-19 22:07:01 +0000
commitcd98370b338a0cc5343067151884a06431a1d92c (patch)
tree7e61d8cf61ada9fef8f470a3c781a07a5df5a0fc /test/Makefile.am
parent394791604a62e19763a8a45328bc5177d91fabf9 (diff)
testing framework, configure fixes, incorporations from meeting, continued work
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 000000000..bf74eaa47
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,23 @@
+if HAVE_CXXTESTGEN
+
+AM_CPPFLAGS = -I. "-I$(CXXTEST)" "-I@top_srcdir@/src/include" "-I@top_srcdir@/src"
+AM_CXXFLAGS = -fno-access-control
+AM_LDFLAGS = -L@top_builddir@/src/libcvc4.a
+TESTS = \
+ expr/expr_black \
+ expr/expr_white
+
+%.cpp: %.h
+ $(CXXTESTGEN) --have-eh --have-std --error-printer -o $@ $<
+%: %.cpp
+ $(CXX) $(TEST_CPPFLAGS) $(AM_CPPFLAGS) $(TEST_CXXFLAGS) $(AM_CXXFLAGS) -o $@ $(TEST_LDFLAGS) $(AM_LDFLAGS) $< @top_builddir@/src/libcvc4.a
+
+MOSTLYCLEANFILES = $(TESTS) $(TESTS:%=%.cpp)
+
+else
+
+# force a user-visible failure for "make check"
+TESTS = no_cxxtest
+
+endif
+
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback