summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-06-03 13:22:57 +0000
committerMorgan Deters <mdeters@gmail.com>2010-06-03 13:22:57 +0000
commit25a999fdfd2e38098d0c8dc6b788c9debe4401d5 (patch)
treeebc41c53aee0c88619d82210f0a0987377d3dfb6 /test/Makefile.am
parentd0dc48f0dcba16849fcc9c8649728d813f7c2305 (diff)
* Added NodeBuilder<>::getChild() to make interface more consistent
with that of Node. * If NodeBuilder<> hasn't yet been assigned a Kind, several member functions related to children now throw an IllegalArgumentException: * getNumChildren() * begin() * end() * operator[] * getChild() This is because if you later assign the NodeBuilder<> a PARAMETERIZED kind, the children are "reinterpreted" -- the first being an operator. Interface-wise, it doesn't make sense to return one thing for nb[0], then later, after setting the kind, to return another thing for nb[0]. * Fixed unit tests depending on this behavior. * Added a warning to the testing summary if unit tests didn't run (because this is likely due to compilation problems, and without a warning it looks kind of like a test success) * VERBOSE wasn't exported to the environment for unit test "make check." Fixed.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index de8e7a985..2b79c5045 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -34,6 +34,9 @@ check-pre:
check-local:
@$(am__tty_colors); \
echo $${blu}=============================== TESTING SUMMARY =============================$$std; \
+ if test -s "unit/test-suite.log"; then :; else \
+ echo "$${red}Unit tests did not run; maybe there were compilation problems ?$$std"; \
+ fi; \
for dir in $(subdirs_to_check); do \
log=$$dir/test-suite.log; \
if test -s "$$log"; then \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback