summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-10-01 15:53:30 -0700
committerGitHub <noreply@github.com>2018-10-01 15:53:30 -0700
commit968d12fb8dc668dde59b02923a6b9ec20ecbeb3f (patch)
tree41bd185dfea8fbf29bb5b083d38e49b3a40c3d9c /test/CMakeLists.txt
parent6b718154dfbf5e9f8506d6911201bb7398ba8b48 (diff)
cmake: Add build target build-tests to build all test dependencies. (#2558)
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index a79e96c65..f601e5247 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -4,6 +4,8 @@
# > regression tests of levels 0 and 1
# > system tests
+add_custom_target(build-tests)
+
# Note: Do not add custom targets for running tests (regress, systemtests,
# units) as dependencies to other run targets. This will result in executing
# tests multiple times. For example, if check would depend on regress it would
@@ -12,7 +14,9 @@
# Dependencies of check are added in the corresponding subdirectories.
add_custom_target(check
COMMAND
- ctest --output-on-failure -LE "regress[2-4]" -j${CTEST_NTHREADS} $(ARGS))
+ ctest --output-on-failure -LE "regress[2-4]" -j${CTEST_NTHREADS} $(ARGS)
+ DEPENDS
+ build-tests)
#-----------------------------------------------------------------------------#
# Add subdirectories
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback