summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAina Niemetz <aina.niemetz@gmail.com>2018-09-14 14:21:35 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commit0a41a21cedc789262f3035aa91ff6b924f309b4e (patch)
treeeae28a622352c818e043b0ac3adba60c3e14a0c3 /test/CMakeLists.txt
parent15a7249a2aa33187e766d6f828a503e5c937b9cf (diff)
cmake: Do not build examples and unit and system tests by default.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 2e062bd85..64fa378ff 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -10,14 +10,14 @@ endif()
# Add subdirectories
add_subdirectory(regress)
-add_subdirectory(system)
+add_subdirectory(system EXCLUDE_FROM_ALL)
if(BUILD_BINDINGS_JAVA)
add_subdirectory(java)
endif()
if(ENABLE_UNIT_TESTING)
- add_subdirectory(unit)
+ add_subdirectory(unit EXCLUDE_FROM_ALL)
endif()
#-----------------------------------------------------------------------------#
@@ -27,4 +27,8 @@ endif()
# > system tests
add_custom_target(check
- COMMAND ctest --output-on-failure -LE "regress[2-4]" -j${NTHREADS} $(ARGS))
+ COMMAND ctest --output-on-failure -LE "regress[2-4]" -j${NTHREADS} $(ARGS)
+ DEPENDS units regress systemtests)
+if(BUILD_BINDINGS_JAVA)
+ add_dependencies(check cvc4javatests)
+endif()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback