summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAina Niemetz <aina.niemetz@gmail.com>2020-09-14 21:21:03 -0700
committerGitHub <noreply@github.com>2020-09-14 23:21:03 -0500
commitcdb338bb5c0fc033f6788549985c5a60ab1323b3 (patch)
treefb6ce5e0c9f17d8fb5ed7c8141a21e037e859ecd /test/CMakeLists.txt
parent2b5902b1c54b1a4717273d501333dd37b8715f9d (diff)
Rename system tests to api tests and remove obsolete Java test. (#5066)
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index cc05aff43..4c8b9d156 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -2,11 +2,11 @@
# Add target 'check', builds and runs
# > unit tests
# > regression tests of levels 0 and 1
-# > system tests
+# > api tests
add_custom_target(build-tests)
-# Note: Do not add custom targets for running tests (regress, systemtests,
+# Note: Do not add custom targets for running tests (regress, apitests,
# units) as dependencies to other run targets. This will result in executing
# tests multiple times. For example, if check would depend on regress it would
# first run the command of the regress target (i.e., run all regression tests)
@@ -24,7 +24,7 @@ add_custom_target(check
if (NOT BUILD_LIB_ONLY)
add_subdirectory(regress)
endif()
-add_subdirectory(system EXCLUDE_FROM_ALL)
+add_subdirectory(api EXCLUDE_FROM_ALL)
if(ENABLE_UNIT_TESTING)
add_subdirectory(unit EXCLUDE_FROM_ALL)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback