summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAndres Noetzli <andres.noetzli@gmail.com>2020-07-01 08:44:21 -0700
committerGitHub <noreply@github.com>2020-07-01 10:44:21 -0500
commit9ce4c3153d42bc079470b7bd73bf131499b3fcbe (patch)
tree40a384f74915e2c009bb2a66bd0295e62edcfc2e /test/CMakeLists.txt
parent04154c08c1af81bb751376ae9379c071a95c5a3f (diff)
Add testing infrastructure for LFSC signatures (#4678)
This commit adds testing infrastructure for LFSC signatures that is enabled when CVC4 is configured with LFSC. The testing infrastructure adopts run_test.py from https://github.com/CVC4/LFSC with minor modifications (mainly adding support for a list of include directories that are searched to resolve *.plf dependencies). The commit uses the existing examples and test files from proofs/signatures as the initial set of tests. Co-authored-by: Alex Ozdemir aozdemir@hmc.edu
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index ad946e3ca..52a999c1b 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -31,3 +31,7 @@ if(ENABLE_UNIT_TESTING)
add_subdirectory(java)
endif()
endif()
+
+if(LFSC_BINARY)
+ add_subdirectory(signatures)
+endif()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback