summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorAndres Noetzli <andres.noetzli@gmail.com>2018-07-08 13:38:45 -0700
committerGitHub <noreply@github.com>2018-07-08 13:38:45 -0700
commit86d9ba4431108e1fd89639e23857631a7380a005 (patch)
tree81e57f2b4594f6e4f80533a00789ece362b93da3 /src/util/Makefile.am
parentad454857a1f57386f7b132c01ad460750ca8d3aa (diff)
Add more sophisticated floating-point sampler (#2155)
This commit adds a floating-point sampler inspired by PyMPF [0]. It also creates a new Sampler class that can be used for creating random values of different sorts (currently BV and FP values). [0] https://github.com/florianschanda/PyMPF
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 9117b9d6b..297d96208 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -19,8 +19,8 @@ libutil_la_SOURCES = \
abstract_value.cpp \
abstract_value.h \
bin_heap.h \
- bitvector.h \
bitvector.cpp \
+ bitvector.h \
bool.h \
cardinality.cpp \
cardinality.h \
@@ -40,16 +40,18 @@ libutil_la_SOURCES = \
ostream_util.cpp \
ostream_util.h \
proof.h \
+ random.cpp \
+ random.h \
regexp.cpp \
regexp.h \
resource_manager.cpp \
resource_manager.h \
result.cpp \
- random.h \
- random.cpp \
result.h \
safe_print.cpp \
safe_print.h \
+ sampler.cpp \
+ sampler.h \
sexpr.cpp \
sexpr.h \
smt2_quote_string.cpp \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback