summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2012-09-22 21:10:51 +0000
committerMorgan Deters <mdeters@gmail.com>2012-09-22 21:10:51 +0000
commite2611a54c5479086df0c4a80f56597aae80b5c4e (patch)
treeb0d98600bd70147f28197883d3481614b87d76f6 /src/util/Makefile.am
parent8b106b77c11d12d16abac845ed704845ef888bd2 (diff)
Separate public-facing and internal-facing interfaces to Statistics.
The external interface (e.g., what's answered by ExprManager::getStatistics() and SmtEngine::getStatistics()) is a snapshot of the current statistics (rather than a reference to the actual StatisticsRegistry). The StatisticsRegistry is now internal-only. However, it's built as a convenience library so that the parser and driver can use it too (by re-linking against it). This is part of the ongoing effort to clean up the public interface. (this commit was certified error- and warning-free by the test-and-commit script.)
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 7d3664d47..7d9a055fd 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -3,13 +3,15 @@ AM_CPPFLAGS = \
-I@srcdir@/../include -I@srcdir@/.. -I@builddir@/..
AM_CXXFLAGS = -Wall -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN)
-noinst_LTLIBRARIES = libutil.la libutilcudd.la
+noinst_LTLIBRARIES = libutil.la libutilcudd.la libstatistics.la
# libutilcudd.la is a separate library so that we can pass separate
# compiler flags
libutilcudd_la_CPPFLAGS = $(CPPFLAGS) $(AM_CPPFLAGS) @CUDD_CPPFLAGS@
libutilcudd_la_LIBADD = @CUDD_LDFLAGS@ @CUDD_LIBS@
+libstatistics_la_CPPFLAGS = $(CPPFLAGS) $(AM_CPPFLAGS) -D__BUILDING_STATISTICS_FOR_EXPORT
+
# Do not list built sources (like integer.h, rational.h, and tls.h) here!
# Rather, list them under BUILT_SOURCES, and their .in versions under
# EXTRA_DIST. Otherwise, they're packaged up in the tarball, which is
@@ -44,8 +46,10 @@ libutil_la_SOURCES = \
gmp_util.h \
sexpr.h \
sexpr.cpp \
- stats.h \
- stats.cpp \
+ statistics.h \
+ statistics.cpp \
+ statistics_registry.h \
+ statistics_registry.cpp \
dynamic_array.h \
language.h \
lemma_input_channel.h \
@@ -81,6 +85,11 @@ libutil_la_SOURCES = \
libutil_la_LIBADD = \
@builddir@/libutilcudd.la
+
+libstatistics_la_SOURCES = \
+ statistics_registry.h \
+ statistics_registry.cpp
+
libutilcudd_la_SOURCES = \
propositional_query.h \
propositional_query.cpp
@@ -110,7 +119,7 @@ EXTRA_DIST = \
integer.h.in \
tls.h.in \
integer.i \
- stats.i \
+ statistics.i \
bool.i \
sexpr.i \
datatype.i \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback