summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorTim King <taking@google.com>2016-01-05 16:29:44 -0800
committerTim King <taking@google.com>2016-01-05 16:29:44 -0800
commit5eabda0f55cee3be81aa7ae126269c32e818322f (patch)
treeb873e4cb8e5d37ff3bb70596494bc5964aaef135 /src/util/Makefile.am
parentb717513e2a1d956c4456d13e0625957fc84c2449 (diff)
Add SmtGlobals Class
- The options replayStream, lemmaInputChannel, lemmaOutputChannel have been removed due to their datatypes. These datatypes were previously pointers to types that were not usable from the options/ library. - The option replayLog has been removed due to inconsistent memory management. - SmtGlobals is a class that wraps a pointer to each of these removed options. These can each be set independently. - There is a single SmtGlobals per SmtEngine with the lifetime of the SmtEngine. - A pointer to this is freely given to the user of an SmtEngine to parameterize the solver after construction. - Selected classes have been given a copy of this pointer in their constructors. - Removed the dependence on Node from Result. Moving Result back into util/.
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 55f1a14da..b06666ae3 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -43,6 +43,8 @@ libutil_la_SOURCES = \
proof.h \
regexp.cpp \
regexp.h \
+ result.cpp \
+ result.h \
smt2_quote_string.cpp \
smt2_quote_string.h \
subrange_bound.cpp \
@@ -89,6 +91,7 @@ EXTRA_DIST = \
rational_gmp_imp.cpp \
rational_gmp_imp.h \
regexp.i \
+ result.i \
subrange_bound.i \
tuple.i \
unsafe_interrupt_exception.i
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback