summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorDejan Jovanović <dejan.jovanovic@gmail.com>2011-09-15 18:17:11 +0000
committerDejan Jovanović <dejan.jovanovic@gmail.com>2011-09-15 18:17:11 +0000
commitdcb2ad496607e2f3821ee84a175a1b412f2f9a20 (patch)
treeefde3ce32d31d097bc8a1b7fb3a4b00bf680ca38 /src/util/Makefile.am
parent72f552ead344b13d90832222157b970ae3dec8ff (diff)
adding --show-debug-tags to list all available debug tracing tags
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am24
1 files changed, 23 insertions, 1 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index f371a4d72..bf975d513 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -75,7 +75,29 @@ libutilcudd_la_SOURCES = \
BUILT_SOURCES = \
rational.h \
integer.h \
- tls.h
+ tls.h \
+ debug_tags.h
+
+debug_tags.h: debug_tags
+ $(AM_V_GEN)( \
+ echo 'const char* debug_tags[] = {'; \
+ first=1; \
+ for tag in `cat debug_tags`; \
+ do \
+ if [ $$first -eq 1 ]; then first=0; else echo ','; fi; \
+ echo -n "\"$$tag\""; \
+ done; \
+ echo; \
+ echo '};' \
+ ) >"$@"
+
+debug_tags:
+ $(AM_V_GEN)\
+ grep 'Debug(\".*\")' `find @srcdir@/../ -name "*.cpp" -or -name "*.h" -or -name "*.cc" -or -name "*.g"` | \
+ sed s/'.*Debug(\"'//g | sed s/'\".*'//g | sort | uniq >"$@"
+
+.PHONY: debug_tags
+
if CVC4_CLN_IMP
libutil_la_SOURCES += \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback