summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorTim King <taking@google.com>2015-12-24 05:38:43 -0500
committerTim King <taking@google.com>2015-12-24 05:38:43 -0500
commita39ad6584c1d61e22e72b53c3838f4f675ed2e19 (patch)
treeed40cb371c41ac285ca2bf41a82254a36134e132 /src/util/Makefile.am
parent87b0fe9ce10d1e5e9ed5a3e7db77f46bf3f68922 (diff)
Miscellaneous fixes
- Splitting the two instances of CheckArgument. The template version is now always defined in base/exception.h and is available in a cvc4_public header. This version has lost its variadic version (due to swig not supporting va_list's). The CPP macro version has been renamed PrettyCheckArgument. (Taking suggestions for a better name.) This is now only defined in base/cvc4_assert.h. Only use this in cvc4_private headers and in .cpp files that can use cvc4_private headers. To use a variadic version of CheckArguments, outside of this scope, you need to duplicate this macro locally. See cvc3_compat.cpp for an example. - Making fitsSignedInt() and fitsUnsignedInt() work more robustly for CLN on 32 bit systems. - Refactoring ArrayStoreAll to avoid potential problems with circular header inclusions. - Changing some headers to use iosfwd when possible.
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 914d6e7d2..55f1a14da 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -45,6 +45,7 @@ libutil_la_SOURCES = \
regexp.h \
smt2_quote_string.cpp \
smt2_quote_string.h \
+ subrange_bound.cpp \
subrange_bound.h \
tuple.h \
unsafe_interrupt_exception.h \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback