summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorTim King <taking@cs.nyu.edu>2011-04-18 16:48:52 +0000
committerTim King <taking@cs.nyu.edu>2011-04-18 16:48:52 +0000
commitabe849b486ea3707fd51a612c7982554f3d6581f (patch)
tree8f3967f644f9098079c778dd60cf9feb36e1ab2b /src/util/Makefile.am
parentb90081962840584bb9eeda368ea232a7d42a292b (diff)
This commit merges the branch arithmetic/propagation-again into trunk.
- This adds code for bounds refinement, and conflict weakening. - This adds util/boolean_simplification.h. - This adds a propagation manager to theory of arithmetic. - Propagation is disabled by default. - Propagation can be enabled by the command line flag "--enable-arithmetic-propagation" - Propagation interacts *heavily* with rewriting equalities, and will work best if the command line flag "--rewrite-arithmetic-equalities" is enabled.
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index eb63885a2..aaf9ca03b 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -47,7 +47,9 @@ libutil_la_SOURCES = \
language.h \
triple.h \
trans_closure.h \
- trans_closure.cpp
+ trans_closure.cpp \
+ boolean_simplification.h
+
libutil_la_LIBADD = \
@builddir@/libutilcudd.la
libutilcudd_la_SOURCES = \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback