summaryrefslogtreecommitdiff
path: root/src/util/CMakeLists.txt
diff options
context:
space:
mode:
authorAina Niemetz <aina.niemetz@gmail.com>2020-11-19 14:05:31 -0800
committerGitHub <noreply@github.com>2020-11-19 14:05:31 -0800
commit7191e58e5561a159c0cd3b81fddbe311ba70a45b (patch)
treed270db3e145e40d25135dfaafb90589750fa4215 /src/util/CMakeLists.txt
parent6d6428a609d76e62cec5ff0ce2bad36e8afe2601 (diff)
floatingpoint.h: Split in preparation to cleanly separate symFPU glue code. (#5478)
Diffstat (limited to 'src/util/CMakeLists.txt')
-rw-r--r--src/util/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/util/CMakeLists.txt b/src/util/CMakeLists.txt
index 462c9090d..94ded3777 100644
--- a/src/util/CMakeLists.txt
+++ b/src/util/CMakeLists.txt
@@ -8,6 +8,7 @@
## All rights reserved. See the file COPYING in the top-level source
## directory for licensing information.
##
+configure_file(symfpu_literal.h.in symfpu_literal.h)
configure_file(floatingpoint.h.in floatingpoint.h)
configure_file(rational.h.in rational.h)
configure_file(integer.h.in integer.h)
@@ -26,6 +27,8 @@ libcvc4_add_sources(
divisible.cpp
divisible.h
floatingpoint.cpp
+ floatingpoint_size.cpp
+ floatingpoint_size.h
gmp_util.h
hash.h
iand.h
@@ -44,6 +47,7 @@ libcvc4_add_sources(
result.h
regexp.cpp
regexp.h
+ roundingmode.h
safe_print.cpp
safe_print.h
sampler.cpp
@@ -58,6 +62,7 @@ libcvc4_add_sources(
statistics_registry.h
string.cpp
string.h
+ symfpu_literal.cpp
tuple.h
unsafe_interrupt_exception.h
utility.cpp
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback