summaryrefslogtreecommitdiff
path: root/src/util/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2021-04-21 10:21:34 -0700
committerGitHub <noreply@github.com>2021-04-21 10:21:34 -0700
commitae5ee4b07dc3d3c792e7fe7f382ff490dd28aca4 (patch)
treea7c2ab8013f46dbea75fcd6e7da3fb83e2012b2f /src/util/CMakeLists.txt
parent86aa9bc35ba9dc9a57913a2ffc71619c7657cc35 (diff)
Goodbye CVC4, hello cvc5! (#6371)
This commits changes the build system to cvc5 and removes the remaining occurrences of CVC4. It further cleans up outdated/unused scripts in contrib/.
Diffstat (limited to 'src/util/CMakeLists.txt')
-rw-r--r--src/util/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/util/CMakeLists.txt b/src/util/CMakeLists.txt
index e495fd4d6..79a44f426 100644
--- a/src/util/CMakeLists.txt
+++ b/src/util/CMakeLists.txt
@@ -20,7 +20,7 @@ configure_file(rational.h.in rational.h)
configure_file(integer.h.in integer.h)
configure_file(real_algebraic_number.h.in real_algebraic_number.h)
-libcvc4_add_sources(
+libcvc5_add_sources(
abstract_value.cpp
abstract_value.h
bin_heap.h
@@ -84,13 +84,13 @@ libcvc4_add_sources(
)
if(CVC5_USE_CLN_IMP)
- libcvc4_add_sources(rational_cln_imp.cpp integer_cln_imp.cpp)
+ libcvc5_add_sources(rational_cln_imp.cpp integer_cln_imp.cpp)
endif()
if(CVC5_USE_GMP_IMP)
- libcvc4_add_sources(rational_gmp_imp.cpp integer_gmp_imp.cpp)
+ libcvc5_add_sources(rational_gmp_imp.cpp integer_gmp_imp.cpp)
endif()
if(CVC5_USE_POLY_IMP)
- libcvc4_add_sources(real_algebraic_number_poly_imp.cpp real_algebraic_number_poly_imp.h)
+ libcvc5_add_sources(real_algebraic_number_poly_imp.cpp real_algebraic_number_poly_imp.h)
endif()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback