summaryrefslogtreecommitdiff
path: root/src/theory/strings/Makefile.am
diff options
context:
space:
mode:
authorTianyi Liang <tianyi-liang@uiowa.edu>2013-09-11 11:23:19 -0400
committerMorgan Deters <mdeters@cs.nyu.edu>2013-09-11 18:15:18 -0400
commitc3a959b3112af83492694b8f0919381b1c467fb8 (patch)
tree62ae7f49087bfb61a439161b5bc1cb5c8c691f21 /src/theory/strings/Makefile.am
parentf49c16dd1169d3de4bbfcdca22af1269bbd0a005 (diff)
Theory of strings.
Signed-off-by: Morgan Deters <mdeters@cs.nyu.edu>
Diffstat (limited to 'src/theory/strings/Makefile.am')
-rw-r--r--src/theory/strings/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/theory/strings/Makefile.am b/src/theory/strings/Makefile.am
new file mode 100644
index 000000000..15bd04b88
--- /dev/null
+++ b/src/theory/strings/Makefile.am
@@ -0,0 +1,17 @@
+AM_CPPFLAGS = \
+ -D__BUILDING_CVC4LIB \
+ -I@srcdir@/../../include -I@srcdir@/../.. -I@builddir@/../..
+AM_CXXFLAGS = -Wall $(FLAG_VISIBILITY_HIDDEN)
+
+noinst_LTLIBRARIES = libstrings.la
+
+libstrings_la_SOURCES = \
+ theory_strings.h \
+ theory_strings.cpp \
+ theory_strings_rewriter.h \
+ theory_strings_rewriter.cpp \
+ theory_strings_type_rules.h \
+ type_enumerator.h
+
+EXTRA_DIST = \
+ kinds
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback