summaryrefslogtreecommitdiff
path: root/src/theory/rewriterules/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2012-06-11 16:28:23 +0000
committerMorgan Deters <mdeters@gmail.com>2012-06-11 16:28:23 +0000
commit3378e253fcdb34c753407bb16d08929da06b3aaa (patch)
treedb7c7118dd0d1594175b56866f845b42426ae0a7 /src/theory/rewriterules/Makefile.am
parent42794501e81c44dce5c2f7687af288af030ef63e (diff)
Merge from quantifiers2-trunkmerge branch.
Adds TheoryQuantifiers and TheoryRewriteRules, QuantifiersEngine, and other infrastructure. Adds theory instantiators to many theories. Adds the UF strong solver.
Diffstat (limited to 'src/theory/rewriterules/Makefile.am')
-rw-r--r--src/theory/rewriterules/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/theory/rewriterules/Makefile.am b/src/theory/rewriterules/Makefile.am
new file mode 100644
index 000000000..46cffda11
--- /dev/null
+++ b/src/theory/rewriterules/Makefile.am
@@ -0,0 +1,19 @@
+AM_CPPFLAGS = \
+ -D__BUILDING_CVC4LIB \
+ -I@srcdir@/../../include -I@srcdir@/../.. -I@builddir@/../..
+AM_CXXFLAGS = -Wall -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN)
+
+noinst_LTLIBRARIES = librewriterules.la
+
+librewriterules_la_SOURCES = \
+ theory_rewriterules_rules.h \
+ theory_rewriterules_rules.cpp \
+ theory_rewriterules.h \
+ theory_rewriterules.cpp \
+ theory_rewriterules_rewriter.h \
+ theory_rewriterules_type_rules.h \
+ theory_rewriterules_preprocess.h \
+ theory_rewriterules_params.h
+
+EXTRA_DIST = \
+ kinds
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback