summaryrefslogtreecommitdiff
path: root/src/theory/bv/Makefile.am
diff options
context:
space:
mode:
authorLiana Hadarean <lianahady@gmail.com>2012-02-25 18:23:10 +0000
committerLiana Hadarean <lianahady@gmail.com>2012-02-25 18:23:10 +0000
commit7aa55e0d38e73a02b11ad0c5a60196b610674050 (patch)
treec59def0ed00dcde29a5a6498cf74ac87dc3a2a6f /src/theory/bv/Makefile.am
parentd8da6a3644d1cdbe62d44a8eb80068da4d1d2855 (diff)
Refactored CnfStream to work with the bv theory Bitblaster:
* separated SatSolverInput interface class into two classes: - TheoryProxy for the sat solver to communicate with the theories - SatSolverInterface abstract class to communicate with the sat solver * instead of using #ifdef typedef for SatClauses and SatLiterals, now there are CVC4 SatLiteral/SatClause types and mappings between them and the internal sat solver clause/literal representation * added abstract classes for DPLLSatSolver and BVSatSolver different interfaces Replaced TheoryBV with bitblasting implementation: * all operators bitblasted * only operator elimination rewrite rules so far
Diffstat (limited to 'src/theory/bv/Makefile.am')
-rw-r--r--src/theory/bv/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/src/theory/bv/Makefile.am b/src/theory/bv/Makefile.am
index 08dde4349..1b8e902e0 100644
--- a/src/theory/bv/Makefile.am
+++ b/src/theory/bv/Makefile.am
@@ -1,22 +1,26 @@
AM_CPPFLAGS = \
-D__BUILDING_CVC4LIB \
+ -D __STDC_LIMIT_MACROS \
+ -D __STDC_FORMAT_MACROS \
-I@srcdir@/../../include -I@srcdir@/../.. -I@builddir@/../..
AM_CXXFLAGS = -Wall -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN)
noinst_LTLIBRARIES = libbv.la
libbv_la_SOURCES = \
+ theory_bv_utils.h \
+ bv_sat.h \
+ bv_sat.cpp \
+ bitblast_strategies.h \
+ bitblast_strategies.cpp \
theory_bv.h \
theory_bv.cpp \
- theory_bv_utils.h \
theory_bv_rewrite_rules.h \
theory_bv_rewrite_rules_core.h \
+ theory_bv_rewrite_rules_arith.h \
theory_bv_type_rules.h \
theory_bv_rewriter.h \
theory_bv_rewriter.cpp \
- equality_engine.h \
- equality_engine.cpp \
- slice_manager.h \
cd_set_collection.h
EXTRA_DIST = kinds
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback