summaryrefslogtreecommitdiff
path: root/src/theory/arith/Makefile.am
diff options
context:
space:
mode:
authorTim King <taking@cs.nyu.edu>2010-05-19 21:20:54 +0000
committerTim King <taking@cs.nyu.edu>2010-05-19 21:20:54 +0000
commitff70395fd3dcde9f68eda1c6a8bd70e6491f7458 (patch)
treed0cf52a5e6cb98a0aa6c15ca4c4fe4d258cb626f /src/theory/arith/Makefile.am
parent07e1a1668a27e90563f23bcf5abb5cb7fe30da86 (diff)
Significant revision to theory/arith. The new draft has a lot of small bug fixes and organizational changes. The theory is now enabled to perform checking in the TheoryEngine. This draft can now solve 2 new regression tests test/regress/regress0/ineq_slack.smt and test/regress/regress0/ineq_basic.smt. There is also a small bug fix inside src/expr/attribute.h.
Diffstat (limited to 'src/theory/arith/Makefile.am')
-rw-r--r--src/theory/arith/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/src/theory/arith/Makefile.am b/src/theory/arith/Makefile.am
index 0428bf84e..ae9d3aab7 100644
--- a/src/theory/arith/Makefile.am
+++ b/src/theory/arith/Makefile.am
@@ -6,16 +6,20 @@ AM_CXXFLAGS = -Wall $(FLAG_VISIBILITY_HIDDEN)
noinst_LTLIBRARIES = libarith.la
libarith_la_SOURCES = \
- theory_arith.h \
- theory_arith.cpp \
theory_arith_type_rules.h \
arith_rewriter.h \
arith_rewriter.cpp \
arith_utilities.h \
arith_constants.h \
+ delta_rational.h \
+ delta_rational.cpp \
+ partial_model.h \
+ partial_model.cpp \
basic.h \
normal.h \
slack.h \
- tableau.h
+ tableau.h \
+ theory_arith.h \
+ theory_arith.cpp
EXTRA_DIST = kinds
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback