summaryrefslogtreecommitdiff
path: root/src/theory/arith/Makefile.am
diff options
context:
space:
mode:
authorTim King <taking@cs.nyu.edu>2010-04-28 20:14:17 +0000
committerTim King <taking@cs.nyu.edu>2010-04-28 20:14:17 +0000
commitc59fe5b21c218d3d6048cc5c34a7e27b3643ae78 (patch)
treebfd3c1d1eb975989b0ef4afa4e88da4eae84ba62 /src/theory/arith/Makefile.am
parent2482b19ea90183d5040390b87877b7593021032c (diff)
Merging the arithmetic theory draft (lra-init) back into the main trunk. This should not affect other parts of the system. This code is untested, and is volatile. It is going to be improved in the future so don't pick on it too much. I am merging this code in its current state back into the main trunk because it was getting unruly to keep merging the updated trunk back into the branch.
Diffstat (limited to 'src/theory/arith/Makefile.am')
-rw-r--r--src/theory/arith/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/theory/arith/Makefile.am b/src/theory/arith/Makefile.am
index cb838f497..7c3e76d0a 100644
--- a/src/theory/arith/Makefile.am
+++ b/src/theory/arith/Makefile.am
@@ -6,6 +6,15 @@ AM_CXXFLAGS = -Wall $(FLAG_VISIBILITY_HIDDEN)
noinst_LTLIBRARIES = libarith.la
libarith_la_SOURCES = \
- theory_arith.h
+ theory_arith.h \
+ theory_arith.cpp \
+ arith_rewriter.h \
+ arith_rewriter.cpp \
+ arith_utilities.h \
+ arith_constants.h \
+ basic.h \
+ normal.h \
+ slack.h \
+ tableau.h
EXTRA_DIST = kinds
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback