summaryrefslogtreecommitdiff
path: root/src/theory/arith/Makefile.am
diff options
context:
space:
mode:
authorTim King <taking@cs.nyu.edu>2011-05-31 01:06:16 +0000
committerTim King <taking@cs.nyu.edu>2011-05-31 01:06:16 +0000
commit46a299aa48bcb0bff64bdb607f61f75a05987962 (patch)
tree3880ed92599b84b59d4b135ab4513dd7c50f76e4 /src/theory/arith/Makefile.am
parentb9ffc0f2cf5d2f05e5269ffb8b5f58c5d7f71e0c (diff)
This commit contains the code for allowing arbitrary equalities in the theory of arithmetic.
* This code has been partially tested. (My testing situation is currently not so great.) The code for testing not preregistering equalities can be compile time enabled by setting the boolean turnOffEqualityPreRegister. Don't be shocked by slowdowns or failures. This does pass make regress as well as a fresh checkout does. (The Mac version has issues.) * I need to disable the permanent row removal heuristic by default. We need to discuss why this needs to happen. We should probably detect pure QF_LRA/QF_RDL problems and enable this when this can safely be done. * I have disabled the arithmetic rewrite equality flag. This code needs to be added to the parser. * For all of the above changes, I have annotated the code with the key word BREADCRUMB. * I have renamed ArithUnatePropagator to ArithAtomDatabase.
Diffstat (limited to 'src/theory/arith/Makefile.am')
-rw-r--r--src/theory/arith/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/theory/arith/Makefile.am b/src/theory/arith/Makefile.am
index c5534560b..7f193b9e3 100644
--- a/src/theory/arith/Makefile.am
+++ b/src/theory/arith/Makefile.am
@@ -14,6 +14,8 @@ libarith_la_SOURCES = \
arith_prop_manager.h \
arith_prop_manager.cpp \
arithvar_node_map.h \
+ atom_database.h \
+ atom_database.cpp \
normal_form.h\
normal_form.cpp \
arith_utilities.h \
@@ -29,8 +31,6 @@ libarith_la_SOURCES = \
arith_priority_queue.cpp \
simplex.h \
simplex.cpp \
- unate_propagator.h \
- unate_propagator.cpp \
theory_arith.h \
theory_arith.cpp
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback