summaryrefslogtreecommitdiff
path: root/src/theory/arith/Makefile.am
diff options
context:
space:
mode:
authorTim King <taking@cs.nyu.edu>2011-04-18 16:48:52 +0000
committerTim King <taking@cs.nyu.edu>2011-04-18 16:48:52 +0000
commitabe849b486ea3707fd51a612c7982554f3d6581f (patch)
tree8f3967f644f9098079c778dd60cf9feb36e1ab2b /src/theory/arith/Makefile.am
parentb90081962840584bb9eeda368ea232a7d42a292b (diff)
This commit merges the branch arithmetic/propagation-again into trunk.
- This adds code for bounds refinement, and conflict weakening. - This adds util/boolean_simplification.h. - This adds a propagation manager to theory of arithmetic. - Propagation is disabled by default. - Propagation can be enabled by the command line flag "--enable-arithmetic-propagation" - Propagation interacts *heavily* with rewriting equalities, and will work best if the command line flag "--rewrite-arithmetic-equalities" is enabled.
Diffstat (limited to 'src/theory/arith/Makefile.am')
-rw-r--r--src/theory/arith/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/theory/arith/Makefile.am b/src/theory/arith/Makefile.am
index 12088b493..c5534560b 100644
--- a/src/theory/arith/Makefile.am
+++ b/src/theory/arith/Makefile.am
@@ -11,6 +11,9 @@ libarith_la_SOURCES = \
arith_rewriter.cpp \
arith_static_learner.h \
arith_static_learner.cpp \
+ arith_prop_manager.h \
+ arith_prop_manager.cpp \
+ arithvar_node_map.h \
normal_form.h\
normal_form.cpp \
arith_utilities.h \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback