summaryrefslogtreecommitdiff
path: root/src/theory/arith/Makefile.am
diff options
context:
space:
mode:
authorTim King <taking@cs.nyu.edu>2010-10-28 21:46:44 +0000
committerTim King <taking@cs.nyu.edu>2010-10-28 21:46:44 +0000
commit50622574025f55417be020f30a4787714977ddd1 (patch)
treecd5a5e944216d354a4745e223aed64d3307ffde6 /src/theory/arith/Makefile.am
parentd2ff1974a7cd87d841e1bcaeb0d93665f70d9259 (diff)
The Row implementation has no been replaced by RowVector and ReducedRowVector. A RowVector is an array of ArithVar and Rational pairs. (This replaces a map based implementation in Row.) ReducedRowVector is a RowVector with a notion of having a basic variable. The Tableau is now a collection of ReduceRowVector's. A major difference between ReducedRowVectors and Rows is that the iterator now includes the basic variable and its coefficient (always -1). Before only nonbasic members were accessible by the iterator.
Diffstat (limited to 'src/theory/arith/Makefile.am')
-rw-r--r--src/theory/arith/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/theory/arith/Makefile.am b/src/theory/arith/Makefile.am
index 21ec99390..907c8820f 100644
--- a/src/theory/arith/Makefile.am
+++ b/src/theory/arith/Makefile.am
@@ -21,6 +21,8 @@ libarith_la_SOURCES = \
arithvar_dense_set.h \
tableau.h \
tableau.cpp \
+ row_vector.h \
+ row_vector.cpp \
arith_propagator.h \
arith_propagator.cpp \
theory_arith.h \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback