summaryrefslogtreecommitdiff
path: root/src/theory/Makefile.am
diff options
context:
space:
mode:
authorClark Barrett <barrett@cs.nyu.edu>2012-06-04 22:26:40 +0000
committerClark Barrett <barrett@cs.nyu.edu>2012-06-04 22:26:40 +0000
commit3609fb41d7744b3a7d74e44f7bedc4d4c522c938 (patch)
tree011a3fa796fdb98bb3b9a1b425d12c678535f294 /src/theory/Makefile.am
parent468c5bc5d8b63ec6818813270225e09383dd79ff (diff)
Added preprocessing pass that propagates unconstrained values - solves all of
the unconstrained examples in QF_AUFBV/brummayerbiere3 - should also help generally on at least BV and maybe others. Off by default for now - results are mixed and it's hard to evaluate with so many existing assertion failures and segfaults - will re-evaluate once those are fixed
Diffstat (limited to 'src/theory/Makefile.am')
-rw-r--r--src/theory/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/theory/Makefile.am b/src/theory/Makefile.am
index 1341c048a..85d6fbdf8 100644
--- a/src/theory/Makefile.am
+++ b/src/theory/Makefile.am
@@ -31,7 +31,9 @@ libtheory_la_SOURCES = \
term_registration_visitor.h \
term_registration_visitor.cpp \
ite_simplifier.h \
- ite_simplifier.cpp
+ ite_simplifier.cpp \
+ unconstrained_simplifier.h \
+ unconstrained_simplifier.cpp
nodist_libtheory_la_SOURCES = \
rewriter_tables.h \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback