summaryrefslogtreecommitdiff
path: root/src/theory/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-07-04 02:00:42 +0000
committerMorgan Deters <mdeters@gmail.com>2010-07-04 02:00:42 +0000
commitcc726b5080f8926a3cb96a1b9d1098ad8725ab86 (patch)
treee27572b69cefa5cbc2addb6e19c0c5a13e402746 /src/theory/Makefile.am
parent33f1138d8ab09bf133b945647d9239befe297d5e (diff)
make dist && make distcheck functional, other fixes
Diffstat (limited to 'src/theory/Makefile.am')
-rw-r--r--src/theory/Makefile.am22
1 files changed, 14 insertions, 8 deletions
diff --git a/src/theory/Makefile.am b/src/theory/Makefile.am
index a2a206d40..ce15b86d4 100644
--- a/src/theory/Makefile.am
+++ b/src/theory/Makefile.am
@@ -6,12 +6,15 @@ AM_CXXFLAGS = -Wall -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN)
noinst_LTLIBRARIES = libtheory.la
libtheory_la_SOURCES = \
- @srcdir@/theoryof_table.h \
+ output_channel.h \
+ interrupted.h \
theory_engine.h \
theory_engine.cpp \
theory_test_utils.h \
theory.h \
theory.cpp
+nodist_libtheory_la_SOURCES = \
+ theoryof_table.h
libtheory_la_LIBADD = \
@builddir@/builtin/libbuiltin.la \
@@ -22,12 +25,19 @@ libtheory_la_LIBADD = \
@builddir@/bv/libbv.la
EXTRA_DIST = \
- @srcdir@/theoryof_table.h \
- theoryof_table_template.h
+ theoryof_table_template.h \
+ mktheoryof \
+ Makefile.subdirs
+
+BUILT_SOURCES = \
+ theoryof_table.h
+
+CLEANFILES = \
+ theoryof_table.h
include @top_srcdir@/src/theory/Makefile.subdirs
-@srcdir@/theoryof_table.h: theoryof_table_template.h mktheoryof @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
+theoryof_table.h: theoryof_table_template.h mktheoryof @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
$(AM_V_at)chmod +x @srcdir@/mktheoryof
$(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
$(AM_V_GEN)(@srcdir@/mktheoryof \
@@ -35,8 +45,4 @@ include @top_srcdir@/src/theory/Makefile.subdirs
`cat @top_builddir@/src/theory/.subdirs` \
> $@) || (rm -f $@ && exit 1)
-BUILT_SOURCES = @srcdir@/theoryof_table.h
-dist-hook: @srcdir@/theoryof_table.h
-MAINTAINERCLEANFILES = @srcdir@/theoryof_table.h
-
SUBDIRS = builtin booleans uf arith arrays bv
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback