summaryrefslogtreecommitdiff
path: root/src/theory/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2011-04-18 08:59:09 +0000
committerMorgan Deters <mdeters@gmail.com>2011-04-18 08:59:09 +0000
commitb90081962840584bb9eeda368ea232a7d42a292b (patch)
treec0f568bc787744a5d53b79a818c0f1bd819596cf /src/theory/Makefile.am
parent7d281fba79b1c9f3ae646d3371a0e52e2efd3bba (diff)
Partial merge from datatypes-merge branch:
1. Defines a new type "DatatypeType", a type-constant that holds a Datatype, describing an inductive data type. 2. CVC language parser supports datatypes. 3. CVC language printer now functional. 4. Minor other cleanups. No performance impact is expected outside of datatypes. I'm verifying that that is the case with a cluster job this morning.
Diffstat (limited to 'src/theory/Makefile.am')
-rw-r--r--src/theory/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/theory/Makefile.am b/src/theory/Makefile.am
index b72502eca..0d680f4c9 100644
--- a/src/theory/Makefile.am
+++ b/src/theory/Makefile.am
@@ -3,7 +3,7 @@ AM_CPPFLAGS = \
-I@srcdir@/../include -I@srcdir@/.. -I@builddir@/..
AM_CXXFLAGS = -Wall -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN)
-SUBDIRS = builtin booleans uf arith arrays bv
+SUBDIRS = builtin booleans uf arith arrays bv datatypes
noinst_LTLIBRARIES = libtheory.la
@@ -36,7 +36,8 @@ libtheory_la_LIBADD = \
@builddir@/uf/libuf.la \
@builddir@/arith/libarith.la \
@builddir@/arrays/libarrays.la \
- @builddir@/bv/libbv.la
+ @builddir@/bv/libbv.la \
+ @builddir@/datatypes/libdatatypes.la
EXTRA_DIST = \
rewriter_tables_template.h \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback