summaryrefslogtreecommitdiff
path: root/src/theory/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2009-12-10 17:45:43 +0000
committerMorgan Deters <mdeters@gmail.com>2009-12-10 17:45:43 +0000
commit8b2d1d64b886db4cff74e2a7b1370841979001b2 (patch)
tree522c31719d0aff3bd0c9d42ed7eddf6ada3c4c12 /src/theory/Makefile.am
parent2f121daa042c6f25a3f9ed8ece60ac5dccb11976 (diff)
cleanups, assert work, add a stubbed uf theory, fix driver
Diffstat (limited to 'src/theory/Makefile.am')
-rw-r--r--src/theory/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/src/theory/Makefile.am b/src/theory/Makefile.am
index 60d11ba88..f8e9908c9 100644
--- a/src/theory/Makefile.am
+++ b/src/theory/Makefile.am
@@ -2,9 +2,15 @@ INCLUDES = -I@srcdir@/../include -I@srcdir@/..
AM_CXXFLAGS = -Wall -fvisibility=hidden
AM_CPPFLAGS = -D__BUILDING_CVC4LIB
-#noinst_LTLIBRARIES = libtheory.la
+noinst_LTLIBRARIES = libtheory.la
-#libtheory_la_LIBADD =
-# @builddir@/uf/libuf.la
+libtheory_la_SOURCES = \
+ theory_engine.h \
+ theory_engine.cpp \
+ theory.h \
+ theory.cpp
-#SUBDIRS = uf
+libtheory_la_LIBADD = \
+ @builddir@/uf/libuf.la
+
+SUBDIRS = uf
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback