summaryrefslogtreecommitdiff
path: root/src/theory/Makefile.am
diff options
context:
space:
mode:
authorClark Barrett <barrett@cs.nyu.edu>2012-05-11 14:00:27 +0000
committerClark Barrett <barrett@cs.nyu.edu>2012-05-11 14:00:27 +0000
commit57790a14676596e8c6ed42ff7ecd8038ddbaf09b (patch)
tree7e4d5c81f197beab924092fb72cc945d48a47e69 /src/theory/Makefile.am
parent5181426cd8def23d67b69227fff033ef12850e68 (diff)
Added some ITE rewrites,
Added ITE simplifier - on by default only for QF_LIA benchmarks Fixed one bug in arrays Added negate() to node.h - it returns kind == NOT ? kind[0] : kind.notNode()
Diffstat (limited to 'src/theory/Makefile.am')
-rw-r--r--src/theory/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/theory/Makefile.am b/src/theory/Makefile.am
index 4a077450c..992796ebb 100644
--- a/src/theory/Makefile.am
+++ b/src/theory/Makefile.am
@@ -29,7 +29,9 @@ libtheory_la_SOURCES = \
shared_terms_database.h \
shared_terms_database.cpp \
term_registration_visitor.h \
- term_registration_visitor.cpp
+ term_registration_visitor.cpp \
+ ite_simplifier.h \
+ ite_simplifier.cpp
nodist_libtheory_la_SOURCES = \
rewriter_tables.h \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback