summaryrefslogtreecommitdiff
path: root/src/theory/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2012-06-11 16:28:23 +0000
committerMorgan Deters <mdeters@gmail.com>2012-06-11 16:28:23 +0000
commit3378e253fcdb34c753407bb16d08929da06b3aaa (patch)
treedb7c7118dd0d1594175b56866f845b42426ae0a7 /src/theory/Makefile.am
parent42794501e81c44dce5c2f7687af288af030ef63e (diff)
Merge from quantifiers2-trunkmerge branch.
Adds TheoryQuantifiers and TheoryRewriteRules, QuantifiersEngine, and other infrastructure. Adds theory instantiators to many theories. Adds the UF strong solver.
Diffstat (limited to 'src/theory/Makefile.am')
-rw-r--r--src/theory/Makefile.am30
1 files changed, 27 insertions, 3 deletions
diff --git a/src/theory/Makefile.am b/src/theory/Makefile.am
index 85d6fbdf8..19e7d588a 100644
--- a/src/theory/Makefile.am
+++ b/src/theory/Makefile.am
@@ -3,7 +3,7 @@ AM_CPPFLAGS = \
-I@srcdir@/../include -I@srcdir@/.. -I@builddir@/..
AM_CXXFLAGS = -Wall -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN)
-SUBDIRS = builtin booleans uf arith arrays bv datatypes
+SUBDIRS = builtin booleans uf arith arrays bv datatypes quantifiers rewriterules
DIST_SUBDIRS = $(SUBDIRS) example
noinst_LTLIBRARIES = libtheory.la
@@ -33,10 +33,20 @@ libtheory_la_SOURCES = \
ite_simplifier.h \
ite_simplifier.cpp \
unconstrained_simplifier.h \
- unconstrained_simplifier.cpp
+ unconstrained_simplifier.cpp \
+ quantifiers_engine.h \
+ quantifiers_engine.cpp \
+ instantiator_default.h \
+ instantiator_default.cpp \
+ inst_match.h \
+ inst_match_impl.h \
+ inst_match.cpp \
+ trigger.h \
+ trigger.cpp
nodist_libtheory_la_SOURCES = \
rewriter_tables.h \
+ instantiator_tables.cpp \
theory_traits.h
libtheory_la_LIBADD = \
@@ -46,21 +56,27 @@ libtheory_la_LIBADD = \
@builddir@/arith/libarith.la \
@builddir@/arrays/libarrays.la \
@builddir@/bv/libbv.la \
- @builddir@/datatypes/libdatatypes.la
+ @builddir@/datatypes/libdatatypes.la \
+ @builddir@/quantifiers/libquantifiers.la \
+ @builddir@/rewriterules/librewriterules.la
EXTRA_DIST = \
rewriter_tables_template.h \
+ instantiator_tables_template.cpp \
theory_traits_template.h \
mktheorytraits \
mkrewriter \
+ mkinstantiator \
Makefile.subdirs
BUILT_SOURCES = \
rewriter_tables.h \
+ instantiator_tables.cpp \
theory_traits.h
CLEANFILES = \
rewriter_tables.h \
+ instantiator_tables.cpp \
theory_traits.h
include @top_srcdir@/src/theory/Makefile.subdirs
@@ -73,6 +89,14 @@ rewriter_tables.h: rewriter_tables_template.h mkrewriter @top_builddir@/src/theo
`cat @top_builddir@/src/theory/.subdirs` \
> $@) || (rm -f $@ && exit 1)
+instantiator_tables.cpp: instantiator_tables_template.cpp mkinstantiator @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
+ $(AM_V_at)chmod +x @srcdir@/mkinstantiator
+ $(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
+ $(AM_V_GEN)(@srcdir@/mkinstantiator \
+ $< \
+ `cat @top_builddir@/src/theory/.subdirs` \
+ > $@) || (rm -f $@ && exit 1)
+
theory_traits.h: theory_traits_template.h mktheorytraits @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
$(AM_V_at)chmod +x @srcdir@/mktheorytraits
$(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback