summaryrefslogtreecommitdiff
path: root/src/theory/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2012-07-14 22:53:58 +0000
committerMorgan Deters <mdeters@gmail.com>2012-07-14 22:53:58 +0000
commit4941b3c516361183b4623f5660128e4f1bcce809 (patch)
tree5a996a0778b9a78b27b041fa582ff5585b710013 /src/theory/Makefile.am
parent1c42109395b566a0068cc3ae9067fc87ab8f8e7b (diff)
Type enumerator infrastructure and uninterpreted constant support. No support yet for enumerating arrays, or for enumerating non-trivial datatypes.
Diffstat (limited to 'src/theory/Makefile.am')
-rw-r--r--src/theory/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/src/theory/Makefile.am b/src/theory/Makefile.am
index bca96f7d7..1aae03aa5 100644
--- a/src/theory/Makefile.am
+++ b/src/theory/Makefile.am
@@ -13,6 +13,7 @@ libtheory_la_SOURCES = \
logic_info.cpp \
output_channel.h \
interrupted.h \
+ type_enumerator.h \
theory_engine.h \
theory_engine.cpp \
theory_test_utils.h \
@@ -50,7 +51,8 @@ libtheory_la_SOURCES = \
nodist_libtheory_la_SOURCES = \
rewriter_tables.h \
instantiator_tables.cpp \
- theory_traits.h
+ theory_traits.h \
+ type_enumerator.cpp
libtheory_la_LIBADD = \
@builddir@/builtin/libbuiltin.la \
@@ -67,6 +69,7 @@ EXTRA_DIST = \
rewriter_tables_template.h \
instantiator_tables_template.cpp \
theory_traits_template.h \
+ type_enumerator_template.cpp \
mktheorytraits \
mkrewriter \
mkinstantiator \
@@ -75,12 +78,14 @@ EXTRA_DIST = \
BUILT_SOURCES = \
rewriter_tables.h \
instantiator_tables.cpp \
- theory_traits.h
+ theory_traits.h \
+ type_enumerator.cpp
CLEANFILES = \
rewriter_tables.h \
instantiator_tables.cpp \
- theory_traits.h
+ theory_traits.h \
+ type_enumerator.cpp
include @top_srcdir@/src/theory/Makefile.subdirs
@@ -107,3 +112,11 @@ theory_traits.h: theory_traits_template.h mktheorytraits @top_builddir@/src/theo
$< \
`cat @top_builddir@/src/theory/.subdirs` \
> $@) || (rm -f $@ && exit 1)
+
+type_enumerator.cpp: type_enumerator_template.cpp mktheorytraits @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
+ $(AM_V_at)chmod +x @srcdir@/mktheorytraits
+ $(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
+ $(AM_V_GEN)(@srcdir@/mktheorytraits \
+ $< \
+ `cat @top_builddir@/src/theory/.subdirs` \
+ > $@) || (rm -f $@ && exit 1)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback