summaryrefslogtreecommitdiff
path: root/src/theory/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-08-10 16:19:43 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commitd5614f1c7f0380266abf6fd185b13d654657731d (patch)
treef73702f3c2e823a6a785f1465a06d221ef14d07b /src/theory/CMakeLists.txt
parent424923f1317f3182574ebe730ebe0c81b7dbf494 (diff)
cmake: Working build infrastructure.
TODO: cvc4autoconfig.h
Diffstat (limited to 'src/theory/CMakeLists.txt')
-rw-r--r--src/theory/CMakeLists.txt50
1 files changed, 26 insertions, 24 deletions
diff --git a/src/theory/CMakeLists.txt b/src/theory/CMakeLists.txt
index 43592c48b..ab6dd580f 100644
--- a/src/theory/CMakeLists.txt
+++ b/src/theory/CMakeLists.txt
@@ -4,34 +4,36 @@ set(mktheorytraits_script ${CMAKE_CURRENT_LIST_DIR}/mktheorytraits)
set(mkrewriter_script ${CMAKE_CURRENT_LIST_DIR}/mkrewriter)
add_custom_command(
- COMMAND
- ${mkrewriter_script}
- ${CMAKE_CURRENT_LIST_DIR}/rewriter_tables_template.h
- ${kinds_files}
- > ${CMAKE_CURRENT_BINARY_DIR}/rewriter_tables.h
- DEPENDS mkrewriter rewriter_tables_template.h
- OUTPUT rewriter_tables.h
- COMMENT "Generating rewriter_tables.h."
+ OUTPUT rewriter_tables.h
+ COMMAND
+ ${mkrewriter_script}
+ ${CMAKE_CURRENT_LIST_DIR}/rewriter_tables_template.h
+ ${kinds_files}
+ > ${CMAKE_CURRENT_BINARY_DIR}/rewriter_tables.h
+ DEPENDS mkrewriter rewriter_tables_template.h
)
add_custom_command(
- COMMAND
- ${mktheorytraits_script}
- ${CMAKE_CURRENT_LIST_DIR}/theory_traits_template.h
- ${kinds_files}
- > ${CMAKE_CURRENT_BINARY_DIR}/theory_traits.h
- DEPENDS mktheorytraits theory_traits_template.h
- OUTPUT theory_traits.h
- COMMENT "Generating theory_traits.h."
+ OUTPUT theory_traits.h
+ COMMAND
+ ${mktheorytraits_script}
+ ${CMAKE_CURRENT_LIST_DIR}/theory_traits_template.h
+ ${kinds_files}
+ > ${CMAKE_CURRENT_BINARY_DIR}/theory_traits.h
+ DEPENDS mktheorytraits theory_traits_template.h
)
add_custom_command(
- COMMAND
- ${mktheorytraits_script}
- ${CMAKE_CURRENT_LIST_DIR}/type_enumerator_template.cpp
- ${kinds_files}
- > ${CMAKE_CURRENT_BINARY_DIR}/type_enumerator.cpp
- DEPENDS mktheorytraits type_enumerator_template.cpp
- OUTPUT type_enumerator.cpp
- COMMENT "Generating type_enumerator.cpp."
+ OUTPUT type_enumerator.cpp
+ COMMAND
+ ${mktheorytraits_script}
+ ${CMAKE_CURRENT_LIST_DIR}/type_enumerator_template.cpp
+ ${kinds_files}
+ > ${CMAKE_CURRENT_BINARY_DIR}/type_enumerator.cpp
+ DEPENDS mktheorytraits type_enumerator_template.cpp
+)
+
+add_custom_target(
+ gen-theory-files
+ DEPENDS type_enumerator.cpp theory_traits.h rewriter_tables.h
)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback