summaryrefslogtreecommitdiff
path: root/src/smt/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2012-07-16 15:53:22 +0000
committerMorgan Deters <mdeters@gmail.com>2012-07-16 15:53:22 +0000
commit36615c5e7332e26645b33ce9b6bab25439a5108e (patch)
tree166efefced107009f4a68ff3d0c6623540dfa435 /src/smt/Makefile.am
parent25396f93b7df85c80a39ed207483e28a8c86ff26 (diff)
Support for having two SmtEngines with the same ExprManager.
Basically, this involves creating a separate StatisticsRegistry for the ExprManager and for the SmtEngine. Otherwise, theories register the same statistic twice. This is a larger problem, though, for creating multiple instances of theories, and that is unaddressed. Still, separating out the expr statistics into a separate registry is probably a good idea, since the expr package is somewhat separate anyway (and in the short term it allows two SmtEngines to co-exist).
Diffstat (limited to 'src/smt/Makefile.am')
-rw-r--r--src/smt/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/smt/Makefile.am b/src/smt/Makefile.am
index 3e777ec89..5cc0cedd1 100644
--- a/src/smt/Makefile.am
+++ b/src/smt/Makefile.am
@@ -8,6 +8,8 @@ noinst_LTLIBRARIES = libsmt.la
libsmt_la_SOURCES = \
smt_engine.cpp \
smt_engine.h \
+ smt_engine_scope.cpp \
+ smt_engine_scope.h \
modal_exception.h \
bad_option_exception.h \
no_such_function_exception.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback