summaryrefslogtreecommitdiff
path: root/src/smt/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-01-29 00:05:16 +0000
committerMorgan Deters <mdeters@gmail.com>2010-01-29 00:05:16 +0000
commit2a9e6970b971eb0a9ac4c216fe5f5f1542e195e0 (patch)
tree23631643798b923b7e9883286296269c8f5e772d /src/smt/Makefile.am
parent1e59e3f37ecb7b84371691358f3eb3804a845c04 (diff)
fixed CNF conversion, and more modular; CNF conversion command line option; various cleanups; renamed numChildren() to getNumChildren() and added it to NodeBuilder interface; fancier, non-exponential CNF conversion with variable introduction is still buggy (?)
Diffstat (limited to 'src/smt/Makefile.am')
-rw-r--r--src/smt/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/smt/Makefile.am b/src/smt/Makefile.am
index bd75bacab..fa7fed5f1 100644
--- a/src/smt/Makefile.am
+++ b/src/smt/Makefile.am
@@ -7,4 +7,7 @@ noinst_LTLIBRARIES = libsmt.la
libsmt_la_SOURCES = \
smt_engine.cpp \
- smt_engine.h
+ smt_engine.h \
+ cnf_converter.h \
+ cnf_converter.cpp \
+ cnf_conversion.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback