summaryrefslogtreecommitdiff
path: root/src/prop/Makefile.am
diff options
context:
space:
mode:
authorLiana Hadarean <lianahady@gmail.com>2012-02-25 18:23:10 +0000
committerLiana Hadarean <lianahady@gmail.com>2012-02-25 18:23:10 +0000
commit7aa55e0d38e73a02b11ad0c5a60196b610674050 (patch)
treec59def0ed00dcde29a5a6498cf74ac87dc3a2a6f /src/prop/Makefile.am
parentd8da6a3644d1cdbe62d44a8eb80068da4d1d2855 (diff)
Refactored CnfStream to work with the bv theory Bitblaster:
* separated SatSolverInput interface class into two classes: - TheoryProxy for the sat solver to communicate with the theories - SatSolverInterface abstract class to communicate with the sat solver * instead of using #ifdef typedef for SatClauses and SatLiterals, now there are CVC4 SatLiteral/SatClause types and mappings between them and the internal sat solver clause/literal representation * added abstract classes for DPLLSatSolver and BVSatSolver different interfaces Replaced TheoryBV with bitblasting implementation: * all operators bitblasted * only operator elimination rewrite rules so far
Diffstat (limited to 'src/prop/Makefile.am')
-rw-r--r--src/prop/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/src/prop/Makefile.am b/src/prop/Makefile.am
index 30be07d7c..e6c8752d6 100644
--- a/src/prop/Makefile.am
+++ b/src/prop/Makefile.am
@@ -2,17 +2,21 @@ AM_CPPFLAGS = \
-D__BUILDING_CVC4LIB \
-D __STDC_LIMIT_MACROS \
-D __STDC_FORMAT_MACROS \
- -I@srcdir@/../include -I@srcdir@/.. -I@builddir@/.. -I@srcdir@/minisat
+ -I@srcdir@/../include -I@srcdir@/.. -I@builddir@/.. -I@srcdir@/minisat -I@srcdir@/bvminisat
AM_CXXFLAGS = -Wall -Wno-parentheses -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN)
noinst_LTLIBRARIES = libprop.la
libprop_la_SOURCES = \
+ registrar.h \
prop_engine.cpp \
prop_engine.h \
sat.h \
sat.cpp \
cnf_stream.h \
- cnf_stream.cpp
+ cnf_stream.cpp \
+ sat_module.h \
+ sat_module.cpp
+
+SUBDIRS = minisat bvminisat
-SUBDIRS = minisat
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback